Free Ground Shipping on all orders over $100 (US Only)
login   |   Register

Welcome Forums Tarts for Raspberry Pi TartsSniffer quits with new sensor

This topic contains 3 replies, has 2 voices, and was last updated by Eli Redd Eli Redd 2 years, 6 months ago.

  • Author
    Posts
  • #3874
    Glenn Seaton
    wgseaton
    Participant

    I complied and have running on a Raspberry PI 3 TartsSniffer.
    Learning the sensors and process.
    I have 2 wireless temperature sensors, a dry contact and a 500 V sensor.
    When i first started the app a temperature sensor shows up and request to be registered.
    Then the second but when the dry contact connects the TartsSniffer app exits after reporting New unregistered Sensor.
    Does not show name, option to add, nothing just quits.
    I put trace prints and found it fails when it tries to run.
    strncpy(thisSensorID, gateway->getLastUnknownID(), sizeof(thisSensorID));1

    Any ideas, do i need some startup clear command to sensors that is not in the sniffer app?

    Glenn

  • #3885
    Eli Redd
    Eli Redd
    Participant

    Hello Glenn,

    I would start with identifying the values going into this strncpy. Are they proper values? Is one of those values not properly initialized or defined?

    Let me know if you have questions.

  • #3886
    Glenn Seaton
    wgseaton
    Participant

    I edited and recompiled i think i had changed variable types.

    I have the sniffer working on Pi 3.

    Thanks

  • #3894
    Eli Redd
    Eli Redd
    Participant

    Let us know if you have any other issues. We’re happy to help where we can.

You must be logged in to reply to this topic.

Support
Contact Us!

Your Name (required)

Your Email (required)

Subject

Your Message

Enter this code below: To use CAPTCHA, you need Really Simple CAPTCHA plugin installed.